end of php 5.6 and php 7.0 support

The end of PHP 5.6.x and PHP 7.0.x support – December 2018

The matter is very simple. In December 2018, official support for PHP security fixes for two versions of PHP 5.6.x (end of support December 31, 2018) and PHP 7.0.x (end of support on December 3, 2018) ends.

It is mandatory to update the PHP version to version 7.1 or 7.2. Both are up-to-date, developed and have full support for security patches.

Version 7.1.x will receive amendments until December 1, 2019 and version 7.2 will receive amendments until November 30, 2020.

This is reminded, for example, by Joomla! Message:

Your PHP version, 5.6.30, is only receiving security fixes at this time from the PHP project. This means your PHP version will soon no longer be supported. We recommend planning to upgrade to a newer PHP version before it reaches end of support on 2018-12-31. Joomla will be faster and more secure if you upgrade to a newer PHP version (PHP 7.x is recommended). Please contact your host for upgrade instructions.

How to change the PHP version in cPanel?

To change the PHP version, select the icon in cPanel:

Then indicate the domain for which you want to change the PHP version. The currently recommended version is 7.1 or 7.2

 

NOTE: While Joomla 3.8.x supports PHP 7.2, extensions may be incompatible with this version of PHP. It is worth updating the extensions to the latest version or contact their developers regarding the correct operation of PHP 7.2.

We remind you – the PHP versions of the lines: 5.6.x and 7.0.x stop receiving security patches at the end of December 2018.

Leave a Reply